
Mastercam	X9	Install/Update	Guide 

 

The latest version of Mastercam can be downloaded from here https://www.mastercam.com/en-
us/Support/Downloads   X9 will not be shipped this is a download only version. 

Download Mastercam X9, if asked to run or save choose to save the file.  You will need a registered account at 
www.Mastercam.com, if you do not yet have an account, the process for creating one is at the end of this document. 
*Accounts need to be re-registered every year – see the end of the Document for instructions on Re-registering your 
account* 

**X9 will only run on Professional or Ultimate versions of Windows 7 64bit or Pro and Enterprise versions of 
Windows 8 or 8.1 64bit systems** 

A login with administrative rights should be used to 
when following the instructions in this document. 

Double click on the saved .exe file. 

Choose Ok to accept an English install. 

 



Mastercam X9 – Installation Manager will appear  

   

 

 

 

 

 

 

 

 

 

 

 

 

Check the 
products that you want installed (art and CATIA translators are purchased add-in products, Wire power is for the default 
power libraries for Mastercam Wire) and click on Next. 

 

 

 

 

 

 

 

 

 

 

 

 



To accept the default settings choose next, select configure to change these settings. Some common possible changes- 
metric instead of inches, or a nethasp instead of local hasp. 

 

 

 

 

 

 

 

 

 

 

If you select 

Configure, you can choose your default units, whether you have a local or network hasp *the license key will either be 



on your pc or on the network*, you user name and company and your install folders – we recommend installing to the 
default location   

 

 

 

 

 

 

 

 

 

 

 

 

 

Select Done and then select next to finish the Configure dialog. 

Choose yes to accept the license agreement and select install. 

 

 

 

 

 

 

 

 

 

 

 

 



Mastercam X9 will now be installed on your computer.  Click on Exit to clear the installation dialog and launch 
Mastercam X9 for the first time. 

 

 

 

 

 

 

 

 

 

 

 

 
 

 
 
 
 
 
 
 
 
 
 



Migrating	X8	customized	files	into	X9 
1. Open Mastercam X9 

 
2. This guide is intended for Mastercam users who are using the default file paths in X8. 

This guide will work with non-default paths, but additional steps will be needed if you 
used custom file paths in X8 (for example if you placed your posts or tool libraries on the 
network).  *The additional steps for network installs are mentioned in Step 5* 

 
 

3. In Mastercam X9 choose File>Migration Wizard 
 
 
 

 

 
 
 
 

4. Choose Advanced. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



5. Make sure to choose both – “Migrate shared mcamx files” and “Migrate my mcamx files”.  The source folder will 
automatically direct to your X8 folder path, whether the files are in their default locations or if they are on the 
network.  Click Next. 

**When using network paths** 

We do not suggest editing the destination paths in this step. We suggest updating locally first, and then testing the 
updated files.  Then after testing, the updated local Shared Mcamx9 folder can be copied to the desired Network 
location and Mastercam can be set to use this new path as defined in our network installation guide. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 

6. Select the post related files as shown. 
a. This box needs to be checked to update the .control file. 
b. This box needs to be checked to update the .mmd, .lmd, .wmd, and .rmd files. 
c. This box needs to be checked to update the .pst files. 
d. Click Next. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

7. Check this box to update 
only X8 files, then hit next. 

 
 
 
 
 

 

 
 

8. Choose Finish to start the migration. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



The updating dialog will show while the files are being processed, this may take a few minutes. 

 

 

 

 

 

 

 

9. Click “Yes” to see the results. 
 
 
 
 
 
 
 
 
 

10. The log is displayed. The Migration Wizard will only update your custom files.  Files that were installed with 
Mastercam X8, and have not been changed, will not be updated.  Modified files will be updated, Mastercam checks 
the “modified date” to determine if a file has been changed.  In the below message it shows that 153 files have not 
been modified so they have been skipped. 
 

 
 

11. The Mastercam posts should be ready for use.  Test the code carefully. 
 
 

12. Now we will go through updating other customized files such as tool libraries, operation defaults, configs, etc… Start 
by repeating Steps 3 – 5, then after step 5 continue below with Step 13 which will discuss the most common files 
types that can be updated. 



13. On the file types page- choose your customized files.   Most people will just check boxes b, c, and h - but below are 
descriptions on the different files that can be updated.  If you click on a type it will show you which file extension 
this option will update.*when clicking on a file type a brief description will appear at the bottom of the screen* 

 
a. Check this box if you use the right click import/export functionality in the operations manager 
b. Check this box if you have your operation defaults set – for instance- if you have rapid retract defaulted on- or 

wear cutter comp etc.  *there are new toolpaths in X8, if this box is checked there will be errors when using the 
new toolpaths- click ok on the error, and set up your toolpath, then hit the save parameters to defaults file to 
add it to your defaults file- this fixes the error. 

c. Check this box if you have tool libraries set up with your feeds and speeds, etc.  *If you have custom drawn tools 
see Step 14 on the next page. Check this box if you have customized material selected on the tool setting job 
setup page. 

d. Check this box if you use the Wire product and have customized wire-power libraries. 
e. Check this box if you use a customized setup sheet from the right click setup sheet function. 
f. Check this box if you use the Renishaw probe programming add-in to update the Renishaw posts. 
g. Check this box to update your config- tolerances, converter settings etc. 
h. Check next and repeat steps 7-10 from above to complete the process. 

 
 



14. If you have custom drawn tools, you will need to run the wizard again setting the source folder to the X8 tools folder 
and the destination folder to the X9 tools folder and choosing the part files option on the file types page. 
These screen shots show the default paths for mill tools- the paths may need to be edited to suit your needs. 

 
 

 
 
 
There are a few settings in the Configuration that will need to be looked at after 
updating. 

15. From the Mastercam menu choose Settings>Configuration 
 

16. Choose the Converters topic. 
In X9 every Mastercam seat has the solids option, you may want to change your converter settings to solids and 
Edge curves (instead of Trimmed surfaces and edge curves).  Also you may want to update the to the latest export 
versions as shown below- these versions weren’t available in X8 and are new for X9. 

 

    

 

 



17. Choose the Colors topic – 
Background color is gone in X9 it 
has been combined with 
Gradient start, because of this if 
you had Gradient off in X8, you 
will need to manually turn it off 
in X9 and also set your 
Background color. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

18. If custom toolbars or keyboard shortcuts were used in X8-  
a. From the Mastercam X8 menus choose File>Open User Folder 
b. Open the Config Folder and copy the .workspace files that have been customized 
c. From the Mastercam X9 menus choose File>Open User Folder 
d. Paste the files in the Config Folder 

 

 

 

 

 

 

 

 

 



Website Registration 
To download the latest version of Mastercam you must have a registered account.  You will need to register your 
account every year.  

If you’ve already created and registered your account, but it was over a year ago – 

1. Open X8 or X9, go to the Help menu and choose Link on Mastercam.com 
2. A Dialog box will appear- follow the appropriate instructions. 

 

 

If you do not already have a Registered Account follow the below directions. 

The registration and linking process ensures that only Mastercam customers receive the benefits of Mastercam.com’s 
value-added content such as the Mastercam Forum and Knowledgebase. To register and link, please use the steps 
below: 

2. Launch your web browser and navigate to www.mastercam.com or just click this link: www.mastercam.com . 

3. Click on the Register link in the upper left corner of the Mastercam.com landing page. 



4. When the Create your account page is displayed, enter the required information and then click the Create 
Account button on the bottom of the page.  

 

5. You 

should now see a message that your account was created successfully and an email has been sent to you with 
validation instructions. The email sent address will be donotreply@mastercam.com, so if you do not see the 
email in your inbox please check your spam and junk folders. This activation email will also include your login 
name that was generated automatically. 

6. To validate your account, follow the instruction in the email you received. 
7. Once your account is validated, login using your new ID and the password you created during registration. You 

will be prompted to link your account with your Mastercam SIM. To link your account properly you must 
download and run the linking program to a computer that has Mastercam installed and running. If you have 
Mastercam X7, simply download the linking code generator and copy it into your main Mastercam folder 
(C:\program files\mcamx7 on most systems) and then run the linker from there. If you have an older version of 
Mastercam you will also need to download and install CodeMeter. CodeMeter is already installed with 
Mastercam X7. The linking program and the CodeMeter downloads can be found 
here:  https://www.mastercam.com/en-us/Support-Downloads-Drivers-and-Applets.     



 
Once you have generated a linking code, copy the Linking code into the Account Link Code: edit field and click 
the link my account button. If the computer running Mastercam does not have access to the internet, then save 
the code generated to a text file and then you can finish this process on another computer by just cutting and 
pasting the linking code from the saved text file into the dialog shown below. 

8. Once your account has been linked successfully, log out of your account and then log back in, you should now 
have access to customer-only portions of the website, including the X9 downloads, Mastercam Forum, and 
Knowledge base.  Please note that you MUST have current maintenance to run Mastercam X9. If you are having 
problems registering or linking please email us at qc@mastercam.com. 

 
 
 
Known Issues 

 Problem: User receives error message “The program can’t start because WIBUCM32.dll is missing from your 
computer. Try reinstalling the program to fix this problem.” when running MastercamDotComLinking.exe. 
 

 
 
Solution: Wibu CodeMeter is not installed on the system attempting to generate the linking code. This is 
installed by default on Mastercam X7 and later but is not included with previously released versions. The 
installation can be found on https://www.mastercam.com/en-us/Support-Downloads-Drivers-and-Applets. Be 
sure to select the correct OS-specific version (32- or 64-bit.) 

 Problem: User running a NetHASP cannot generate a linking code using MastercamDotComLinking.exe. 
 



Solution: Users that require the use of nethasp.ini will not be able to generate a linking code for Mastercam.com 
if MastercamDotComLinking.exe is not run from the root directory of the Mastercam installation, which is 
C:\program files\mcamx? (? Denotes version of Mastercam X being used to generate the code). To solve this: 

1. Download MastercamDotComLinking.exe from https://www.mastercam.com/en-us/Support-
Downloads-Drivers-and-Applets. 

2. Place the executable in the root directory of the Mastercam installation. 
3. Run MastercamDotComLinking.exe from this location. The linking code should be generated 

successfully. 
 


